Big Game Fix Live!


Works for me, try starting it in windowed mode. It opened in 4k on first startup on my home PC.


GRID Autosport runs amazingly well just on Gamer settings on Shield Tablet K1.

It took what felt like two minutes to download 13.9 GB through steam servers with a peak download speed of 150 MBps on WiFi . Ethernet on same network gives 72Mbps max in real world.

There were some small audio glitches but gameplay was good quality.


Magicka 2 60 fps all


Hi All,

Maybe you are encuntering the same issues as me. In tow games (Rise of the Tomb Raider and Mass Effect Andromeda) when I start playing it takes about 1-5min and then the game seems to freeze. But in the background I hear the sound of the game. When I press the ESC Key or oder key the game is reacting. Then i change the res 1080p to 720p back to 1080p and it works . But this happens every 5 mins.


Please don’t double post. You’ve already created an identical topic, so this here will only lead to confusion and fragmentation. Thank you very much! :slightly_smiling_face:


Yes same here but my game didn’t crash


Someone should try witcher 3


I’ve played Witcher 3 on Pro, without any issues.


Yeah, works fine on Gamer, too.
Edited the initial post.


Is the driver update live?


Not yet… Sadly :confused: (20 characters are a thing for mods too :stuck_out_tongue: )


Thank you for your response :slight_smile:


how odd…
how to start in windowed mode ? cause when i open the game the skycomputer will crash with internet connection error


Might have to go into the config files and modifying setting from there. It could be in the game install directory or documents depending upon the game. What game are you having trouble with?


I’m not near a computer but from memory, open steam and rightclick on the game and select priperties. The there is a button which says advance startup or launch parameters, something like that and in the box type;


Then press okay and start the game, when I get near a computer I can write a more accurate description.


I can confirm that what @DimMonkey said is correct, you can also do this: -w 1920 -h 1080 to change your resolution(you can change the numbers to any other resolution that you want)


Assassins Creed 3 HD+ Gamer All max in game.

See some input related issues but I’m sure this is my funky hardware config needing tweeked. Not really game issue. PEBSAT.



Has anyone tested this?

I know it’s a old game and that any pc can play it but hey! I would love to be able to play it on my smartphone when I’m not at home!

Thank you!


Far cry primal and da:inqusition work well on new vm.About 60 fps on high graphic settings.Pro


Thanks, added them to the list