Configuration Help Wanted


#1

Good morning,

I recently decided to give this a try for my laptop when I am traveling in the hopes that I can continue to play World of Warcraft without having to shell out for a more powerful gaming laptop as I have a powerful desktop to use when home. I have read a few guides, tips and tricks from several users and managed to get World of Warcraft playing fine with 6ms and 65 FPS in-game however, any other game just simply fails to run at all whether Doom or Stardew Valley (these are examples I just grabbed from my Steam library).

My connection when I work away is 80/20mbit and my home connection is 200/55mbit (this is down/up) which works flawlessly on my desktop and laptop outside of LiquidSky but when using LiquidSky struggles to settle properly.

I have an HP 250 G3, I3-4005U, 8GB RAM + Intel HD4400 inside of this laptop using an SSD (if this matters). As I said, World of Warcraft and other Blizzard games works fine, anytime I try to use Steam for gaming it lags, stutters and such.

I have tried 30FPS, 720p, lowering the presets, changing the CPU priority and affinity, hardware acceleration and such but no luck specifically with anything on Steam. These are both with wired connections that run without issue. I noticed previously that you could change the codec but in these new version that does not seem to be an option? I also run the games at 1366 x 768 the same as the laptop resolution.

Any ideas or help would be appreciated as I’d rather not go and buy a gaming laptop to play when I only travel a few days a month.

Cheers and sorry if this is in the wrong place.

Edit: I am connected to the London Data Centres with very low pings.


#2

Can you try running the client on Windowed Mode and see how it performs with the Steam games.


#3

Can you be specific for this? Does the game not run at all? (Did it spit an error message?)


#4

Also, can you test all these games (working and non-working) at the same time, to rule out server load during peak time?
Your laptop and both networks are way above the minimum requirements, so I don’t see an issue there.


#5

Hey, thanks for the replies. I was at work so only just able to get on.

I will check the lists when I can, window mode makes no difference and I just realised what is happening when trying to play a Steam game. I turned on statistics and noticed when playing World of Warcraft/Diablo 3 that I get no loss (0%) and about 3% jitter. When I try to play a game on Steam I get around 65% loss which fluctuates up or down a few percentage and the jitter shoots up too. This happens in anything Steam related.

Any idea about this?


#6

No idea yet, but that’s actually a very interesting find. Will check that, too, and pass it along to staff. :+1:


#7

Have you tried reinstalling Steam on your SkyComputer? Also if you play the Steam games on your local computer was is the performance?


#8

I can play games like Borderlands (1, 2 and Pre-Sequel), Dishonored, Far Cry 3, Sleeping Dogs and Secret World Legends without issue on the laptop normally, some may be in the lowest settings but they do run on this chipset and playable.

I will try reinstalling Steam when I get a chance later. I’ve not clue why all Blizzard games run fine but Steam suddenly gets a huge loss/jitter happening but will try as you mentioned.


#9

You’re not the only one. I’m no longer using LiquidSky due to this problem!


#11

Yeah, still no luck with reinstalling Steam. It seems to be Steam only causing the issues, Origin, flash in browser and Blizzard games all work fine but Steam just throws everything to 65% loss and high jitter no matter what I try, including another data centre.


#12

Odd, is this on all steam games online and offline?

Have you checked the option for Steam beta client? If so, try again with it unticked. Also, as last resort you can try deleting and recreating your SkyPC with only your steam games on and test it then. There maybe a program eating up resources when Steam is open.


#13

For me, there is no game working.
Isn’t a Intel HD500 + 4GB RAM enough? I can watch 1080p60fps Videos on YT aswell as 4k30fps without lags. Also the client was checking if my PC is good enough for streaming and the video bench status is: passed.
With LiquidSky even Games on lowest streaming settings are unplayable. I have a 120mbit/s bandwith.
The Client shows me, that my datacenter is “Frankfurt” which is perfect for me. But when i do an IP check, it shows USA as location.

This is what im experiencing:


#14

That looks like a network/wifi issue I’m pretty sure, because it looked like this on my old tablet, too. You should either use ethernet, or try WLAN Optimizer (it’s 100% free). Did the trick for me, at least.

The wrong IP location you get from the IP check doesn’t matter. The data center is Frankfurt, only the geolocation is off.


#15

Thanks for your response!
Do i have to active “Streaming Mode” in the WLAN Optimizer?

EDIT:
Mhh. Looks exactly like it did before, even on medium settings.

  • wlan optimizer doesnt help
  • windowed mode for the game wont help
  • my wifi at home is good
  • the wifi on the laptop also works like a charm.

it seems that the n3450 with hd500 cant handle liquid sky


#16

Na, it should be good enough. If your hardware was too weak, you’d rather see insane input lag building up. I’ve been using LiquidSky on a much weaker Asus T100, with Intel Atom Z3775, for almost a year.
https://www.cpubenchmark.net/compare/Intel-Atom-Z3775-vs-Intel-Celeron-N3450/2301vs2907

More things you can try:

  • toggle hardware acceleration (unlikely it will change anything, but can be done in an instant)
  • use ethernet
  • use another network
  • use another device (preferably Android, to have something completely different for comparison)

#17

What laptop is that? Its almost a mac clone to me.
See if changing the power settings to high will reverse the lag.


#18

In my situation I have tried numerous things without luck (mentioned in this thread and otherwise). Steam is the only issue, I can run Blizzard games on high settings with no lag, great performance and such but the moment I run anything on Steam, the loss jumps up to 60% and the moment I exit Steam (close the client) it goes back down. If I then try and run a Blizzard game after this, runs fine so something is off with Steam and as someone said above, they have the same issue with Steam.


#19

Might wanna do a backup just in case (if any games don’t have cloud save) but did you try uninstalling and installing the Steam client from fresh?


#20

Yes, I did a clean install which did not work, tried another SkyComputer or whatever you call it (remade it) and also tried another location. I am using Ethernet and the connection is fine as you can tell from Blizzard games working.

Drivers are all updated to the latest available. I will mainly use this for Battle for Azeroth expansion when out next month when traveling so it is not too much of an issue but I would have liked to sort Steam.


#21

Did you try it on Android or another PC (local)?