Constant bad quality video on a 150Mbps connection in central London (UPDATE)


#1

UPDATE: Been investigating with my ISP. We are trying out a few things. Tested today at 14.22 GMT (so off-peak).
Everything is super smooth, connection is stable. Feels like playing on my normal machine.

Once I have tested during peak hours and weekend I will share with you what we have done to try and solve this issue with the ISP


Hey folks, so I recently decided to give this a try. My little brother always looks at me with envy and my games running in high quality and his PC is a bit 2011. So I am exploring this as an alternative for him and I am happy to get him credits for his game time.

Unfortunately the experience has been less than stellar, has anyone else had issues with a poor quality stream even on fast Fibre Broadband?

So that's the speedtest and then the quality indicator in the SpyPanel

The rig I am testing it on, Core i7 3.8Ghz, 32GB Ram, Nvidia 1080, 1TB Samsung EVO SSD
(edit) I am wired directly into the router also, not wifi.

Im really excited about the tech and this would be a great solution for my little brother so would love to know if there is something I am doing wrong or are the servers currently overoaded?

Best


[Workaround Solution (Solved)] Major artifacts / input lag from Liquidsky
#2

I had some issues with auto, I am up in north west uk on a pretty poor fibre connection, I just unticked auto and I can run at almost full quality at 1080p @ 60fps with little problems, any blips I get are normally down to the wifi.


#3

Thanks for the quick response, let me give that a try. Im testing this against WatchDogs 2 on my steam account as that is what the little bro really wants to get his hands on!


#4

I play all sorts of stuff on here, I have done Shogun 2, Overwatch, Resi 7, FFXIII, Battleborn, GTA5 etc all of them run with reasonable graphics in the normal systems havent even bothered with ultra, I run it all on steam and seems to run fine,


#5

Hey, tried your suggestion, very choppy, keeps stuttering.


#6

Very odd, are you on wifi or ethernet? and to confirm you are just running the games on default settings you are not overriding them to be stupidly high or anything.

A few other things to check, what is the decoding type (i.e CUDA) and can you turn on Steam FPS stats in game, so you can see if the game is rendering at a decent speed and narrow it down to just being your connection.


#7

Do you use your internet for anything else besides LS when using the service? Keep in mind this is a direct, unbuffered stream and that any other connection and downloads (with fluctuating speeds) will affect the incoming stream, be it on your machine or any other device connected to your router.

As an example: Using the IPTV causes no problem whatsoever as it's a constant stream just like LS (with auto-quality off) but when torrents or browser downloads (which have fluctuating data streams) are happening my LS connection starts getting artifacts.

If your router has QoS, try dedicating some of the bandwidth (~30 Mbps) to your lil bro's PC as it may severly reduce the impact from other devices and tell him to not download anything at all while using LS.
If you don't have QoS, maybe you can all consent to only DL or make heavy use of your internet connection when he isn't on LS.


#8

Yeah did that, wired Ethernet to the router, tried a couple of games with low settings. I can see it can handle them .. the screen tears a lot and skips frames, you can even see that when you move a window on the desktop and it stutters while it redraws it, it happens randomly.

Running the ultra tier server.

Yes it says CUDA. Here is a video capture as an example of the tearing and stutters. I have no torrents or browser downloads running. Partner watching Netflix in living room, but same result with it off. I have tried this in off-peak internet hours too with the same result.

Thank you both for taking the time to reply.


#9

You can also hear the audio skipping too


#10

looks like more of a hardware issue then a network


#11

Hmm that is strange indeed. It's not due to heavy use. Maybe it's due to old hardware even though using CUDA isn't giving more than 10ms local latency in which case do try software mode. The only other thing coming to mind is data packet loss, which is a problem on your ISP's side.
I'm in France and my ISP allows me several error correction modes between no error correction at all (meaning data packet loss will not cause the ISP to recall the lost packets) but has the lowest latency, a normal mode which is a decent compromise and a "secure" connection mode which significantly increases latency but recalls every lost packet.

My point is, try out software mode and if it doesn't improve maybe have your ISP do a connection test to see if you're losing data somewhere between your bro's PC and the ISP's local node and if the test doesn't detect anything, maybe you have an option to increase error correction all the while staying at a decent latency.


#12

Im testing it at the moment on my own PC which is a Core i7 3.8Ghz, 32GB Ram, Asus TURBO-GTX1080-​8G, 3 x 1TB Samsung EVO SSD etc etc .. so I am not sure it is hardware from my side.

The packet thing ill find out about, thanks for the suggestion, that could be the issue. He has the same 200Mbs fibre at his place from the same provider so If I manage to solve it here It will sure work for him also.

Again thank you for the suggestion guys.


#13

No problem. Let us know the results. :slight_smile:


#14

Hey iamthedigitalway,

This seems very odd as we rarely ever see performance results like these.

What DataCenter are you connecting to?

However, this seems to be more of a hardware issue from the information you've shared with us so far.

Thanks~


#15

@LiquidSkyJustin

London one. I am based in London, I will dig in deeper with regards to the suggestions and my further testing and I shall report back as soon as I know something. Ill get this working even if it kills me :slight_smile: .. cant wait to see the new launch!

Thanks again!


#16

Small update, so there appears to be a 1-2% Packet loss on my connection which is erratic... will chase ISP to find out why and update soon.


#17

I have a 12mbps connection here and get 60fps 720p on a nexus player I took it over to my sisters house with her 100mbps and it was unplayable.

I turned every thing down low and still had screen tearing heavy pixilation and jittery frames. But we have different internet providers so even with a good speed you can have trouble using it.


#18

So I am a running a monitor on my connection, here are the live results

My Broadband Ping - lucas

Ignore the first bit if data at the start.

Packet loss is almost non existent, there were some small issues but nothing that lasts a long time, I am still running a few tests on why I am getting such a bad connection. Will keep you posted.


#19

i spy the graph of a VirginMedia connection! :slight_smile:

Are you using the New Superhub3? The reason I ask is they are having some known issues with latency sensitive applications like LS


#20

Haha yes James :slight_smile: Virgin Media guilty as charged.

Its superhub 2 .... do you think getting a new router and running the VM Hub in modem mode would help?

My Download is pretty stable at 100-180Mbps usually so bandwidth isn't the issue.