F12 and desktop issue


#1

My apologies for throwing two separate issues into one message.

I encounter these two problems on a regular basis:

  • F12 button doesn’t work when I press it. Mouse is stuck in “jitter mode”. There is also the blue circle that wouldn’t go away. I know this has been discussed before. Any updates on this? I basically have to log out several times and then log back in in hopes of making it work. Sometimes I just have to abandon the session.

  • This is new. When I use the desktop I am not able to make shortcuts clickable. It’s like the mouse ignores anything that isn’t the wallpaper. Again, have to log out… rinse and repeat. Any ideas?

Thanks.


#2

Sounds like the old mouse bug that has been fixed last week or so. Have you tried to reinstall the client? I mean, delete the LiquidSky folder in %appdata%, then redownload the exe from the LS website?


#3

Thanks. I did as you suggested. So far so good. Will report back if I encounter it again…

Do you think the other issue I mentioned has also to do with the mouse bug?


#4

Both were somehow mouse related. I don’t know if they’re caused by the same bug. So you still can’t click anything on your SkyPC desktop?


#5

Yup, still not able to do it. I’m logging in through Steam directly to bypass, the desktop is useless to me right now. Nothing works.


#6

Try using an onscreen keyboard in the meantime as a workaround until this is solved.


#7

I have already reported this to the devs so they can take a look again.


#8

Thanks, all.

I have done some more digging and I feel it’s definitely a mouse issue. I am unable to make the on-screen keyboard work. The mouse doesn’t affect the on/off field. There is a shortcut but I couldn’t find a way to make it work inside the Sky PC.

What the mouse is doing is when I point it, is that it “points” sideways. So if I want to open a folder, I need to point the mouse above it and to the side and not directly to it. Even this only works half the time. Desktop shortcuts remain closed no matter what I do. Even if i highlight them with the “sideways” method and click Enter they still would not open.

This also happens to a degree in the Steam Big Picture mode. The mouse doesn’t point correctly. But over there I just move with the keyboard arrows and press enter and it works.

This was also happening intermittently inside the games themelves (the mouse would not respond with the F12, or it would create a separate “sideways” pointer that would not go away), but last time I played it was fine. However, it seems like in the desktop it is being more persistent.


#9

Please try changing the display settings on your local computer and let us know if that helped.
Here is how you can do it:

Right click your desktop>Display Settings>Make sure text size is set to 100%.


#10

Ha.
Now it’s working.
I was on 125 percent. 100 percent usually is too small for me.
So it’s not a bug after all?

Why is the text size causing this, and is there another way or is this the only solution?

Thanks!


#11

Glad it’s working for you now!

It’s most likely related to the way Windows (your local Windows) applies screen scaling. It also scales apps when you increase the text size, so that’s why the mouse is off in the LS client.


#12

#13

#14

Yes, but I didn’t change the text size before and it worked fine… what would cause that? it’s odd it started acting up all of a sudden.
Also, does the text size affects the issues I had in-game or are those separate? (you mentioned a bug)


#15

Can’t really say because I’m no dev, who knows what has been done in the background.
But it’s very well possible you’ve been encountering separate bugs. Just keep an eye out, and if it happens again, report back.