Kicking me off for being idle while playing


I recently reinstalled the liquid sky application because i kept getting a HTTP error every time i tried to play today. After i reinstalled it i started playing a few matches of overwatch in competitive. In the middle of the match my liquidsky computer popped up with the message "We are having a connection issue or your computer is restoring" I wait a while and it then pops up with something like this: "You have been logged off for being inactivity 30 minutes to preserve your sky credits." I'm currently on the mac version of liquidsky version 0.0.41


Known issue. If you're not on the unlimited plan just disable the timeout in the settings. Alternatively and to avoid some other annoying bugs, you can run the Windows .40 client through Wine.


Same issue, with Star Trek Online. Logged out due to "inactivity," even though I was literally clicking on things at the exact moment that I was supposedly inactive. Unlimited here, so I can't disable the timeout =(


To follow up on @Jimmy's suggestion, you can also run the Windows LiquidSky client in Crossover (if you already have it, WINE or PlayOnMac/PlayOnLinux works fine so no need to buy Crossover just for this).


Same issue, also 0.0.41 on mac. Afterwards the client is no longer connecting untill a complete reset.


Even if i alttab out of a game, click around on the desktop and go back to the game the inputs are completely ignored and the instance shuts down after the set time. (max 60 minutes).
I thought to use LS to play games that i can not play on any other platform. That makes it extra sour that this strange behaviour is mac client specific.
I revise my original vision that this was irrirating. It is a showstopper, and i will not spend any more time in LS or get any more credits before this is fixed.


Run the windows 0.40 LS client through Wine/WineBottler/CrossOver. It runs just fine on Macs (or Linux?).

You won't have these bugs but you might get a couple more MS on local latency. Still negligible though.


Your right-hand shift key may also not work in Crossover. Not sure why, but it's consistent for me on MacOS.