Lag / Delay from 3 to 5 seconds

bug

#1

I request your help with the following problem:

During any gameplay occassionally lags occure with a delay between 3 to 5 seconds. Mostly after a preiode of time (ca 20 seconds) the lags are gone. Nevertheless when I hit “Pause/Start”-Button i can here the sounds of the Pause-Menu without any delay, just the screen is still showing the ingame scene.

The issue can be solved by switching to “hardware acceleration” whenever lags occure.

The problem is that with “hardware acceleration” switched on, i have a permanent small delay (less than one second but noticable) - so this cannot be a permanent solution.

Ingame stats show:
delay 11ms
used bandwidth: ca 8 mbit
max bandwidth: ca 11 mbit

Internet connection: 50mbit down / 2 mbit upstream connection.
Intel Core i5-2467M
Intel HD 3000 onboard graphics.

thank you for your help in advance

Philip


#2

Cpu throttling because of overheating? You should run the Windows task manager on your local device, to monitor what’s happening during these lag spikes.


#3

Hardware acceleration toggles between your CPU rendering the image and your GPU (or integrated graphics) rendering the image. If toggling it on stops the problem, then your CPU might be having a hard time rendering the stream by itself.


#4

Yes, it it the cpu’s problem, i used to have a laptop with the same cpu and igpu, but i upgraded to a 3rd generation i5, and i don’t get lag spikes anymore


#5

this is cpu usage during the last lag. Hardware Acceleration switched off.


#6

a screenshot with “Hardware Acceleration” switched on:

CPU Usage is far less; the only problem is the permanent small delay (less than one second) during gameplay.

I have the newest drivers (which are at least 2 years old)…

Any further ideas would be much appreciated :slight_smile:


#7

We’re getting a bit into wilder tweaks here, but if your cpu is capable of decoding the stream, and only struggles when it’s overheating, maybe you can try to underclock it a bit, or shut off two of the four cores?
Either through the BIOS, or maybe Intel® XTU can also underclock? I haven’t done this stuff on PC for many years, so I don’t know what’s the best tool.


#8

XTU works most likely in this case because generally speaking most laptops don’t allow for BIOS tweaking. Shutting off the cores could help, but honestly try the undervolt before doing that, as this might reduce performance generally across the board (although I’ve lived my whole life on 2 cores- now just with hyperthreading :stuck_out_tongue: )


#9

I changed the Windows 7 Power Settings to max. 99% CPU to prevent the CPU switching into Intel Turbo boost.

I will inform you about further improvements :slight_smile:


#10

XTU doesn’t work for laptop(atleast for the 5 different laptops i have at home), i don’t think you can overclock or even underclock a laptop unless it’s a gaming laptop or a overclock/underclock capable laptop


#11

No- I’ve underclocked this Latitude E5440 that I use all the time. It doesn’t have to be just for certain types of laptops. All laptops/CPUs for the most part should be fine (save for something REALLY old like maybe an E8400).


#12

Hmm, weard, i have a latitude e6330 and it doesn’t work


#13

Define “not working”, because this should be applicable to most modern laptops. Are you using something with a Celeron (not super familiar with the Latitude lineup)? Because this kind of laptop is ANCIENT and probably won’t work simply due to age.


#14

I have a 3rd gen i5, but i will reinstall xtu to see what it says exacly
For some reason i am not being able to boot windows, so i will try to fix it,and tell you more tomorrow


#15

Hmm, i just installed it and i figured out the problem, i had to disable driver enforcementcto make it work, but even so, i can only acess 2 options


And here are my pc specs