Liquidsky doesn't run after the latest update


#1

I am a big fan of Liquidsky, but after the latest update, whenever I try to launch a SkyComputer, i always get a green screen.
My SPECS:
OS: Windows 10.
Processor: Pentium® Dual-Core CPU E5500 @ 2.80GHz 2.80Ghz.
RAM: 4GB.
GPU: Intel g41 Express CHIPSET.
I would like to get a solution or a refund instead!


#2

That’s a known bug, and it’s being worked on. No ETA on a fix, but you’re not the only one.


#3

So I literally just wasted my money on nothing? GG, NICE SERVICE! U RUINED IT ALL!!!


#4

It says on the website the minimum hardware specs to run the client. (It is very clearly stated)
You will have to keep waiting for a patch or upgrade as there is no current work arounds at the moment, sorry


#5

Are you kidding me? the application was working fine as I described! that’s a joke


#6

The app can work fine today but it can break tomorrow. There are some Windows 7 users who were using the app but at certain windows updates later it broke functionality.
You can try a Windows reinstall and see if that works, otherwise I’m out of options. Sorry


#7

I am a windows 10 user, & i have tried reinstalling it many times without any luck!