No CUDA option with GeForce 940m


#1

Hello,

As I encounter bad local latency (from 20ms to 30ms+ in game, it doubles the total latency :cry:), I tried multiple settings : Software / DXVA, 720p/1080p, 30fps/60fps, etc... The latency is almost always the same.

So, looking at forums, Reddit, etc... I've read about a Cuda renderer and I discovered that I do not have the option dispite my GPU being CUDA enabled and LiquidSky running on the GPU.

Here are my sytem specs:

Windows 10 Home
Intel Core i7-6500U
6 Go RAM
Nvidia GeForce 940m

(pardon my english)


#2

Have you right clicked liquidsky executable file and in the context menu that appears chosen to execute it using the Nvidia card instead of Intel HD Graphics?


#3

Yes. I have even checked with the control panel if it was really running on the GPU , and it is.


#4

Dude I'm pretty sure that to use liquid sky, all you need to have is a display connected to liquid sky computer so I guess that little ping won't cause you much problems when you are hooked onto liquid sky​:grinning:( pardon me for any errors above as I'm am android user)


#5

It might sound stupid, but have you checked if your graphics driver is properly installed?

In my case, with a gt530m, newest drivers (after 2015) are not compatible with my motherboard bios. Windows throws an error 43 and disables the video card.

My brother's PC has a gt430m, but his processor isn't an APU (no Intel HD graphics), and his motherboard BIOS isn't compatible either. The gt430m 3d aceleration is disabled. Only software and DXVA are available.

I'm waiting for the AMD Ryzen APU launch to upgrade my machine.


#6

My graphics drivers are working, I'm pretty sure of that.
I can run CUDA rendering in Blender3D, for example.

I've found something interesting: I force LiquidSky launch on the integrated GPU (Intel HD 520) and the local latency is ultra low, like < 9ms stable in game with DXVA.


#7

According to LiquidSky homepage, your integrated graphics is more than enough.


#8

Yes, sure it works.
But, still, not being able to choose CUDA when running on a CUDA enabled GPU is still a bug worthy to report. :slight_smile: