Okay, running out of options, LiquidSky is unplayable, internet is not the issue?


#1

So a week or so ago I posted about changing internet service providers. This was due to me moving to another place. The new download speed being 20mbps and 1.9mbps upload speed. My laptop is connected to the modem* via ethernet. The client is running at 720p 60fps. The decoder is Software, I can also use DVXA. The score in the system tab client is 72/100. The ping to the nearest server is 60ms (Queretaro, Mexico) and I am around 300km away from said server(litlte side note here, If I could join the dallas server, the ping to that is 35ms, weird).

The overall quality of this internet connection is weird to me. Twitch streams can load on source when not on peak hours of the day. At peak hours streams on source quality buffer constantly btut streams in the HIGH quality setting have no problem.

Youtube videos load quickly on 720p/60fps. Long videos(1hr+) load steadily, not super fast, but it doesnt stop to buffer/load another portion of the video.

When downloading games on steam, they download on a 2.5mb speed. This speed does not vary that much, the lower it has gotten is 1.9mb.

When trying speedtest, the downlaod speed stays at those 20mbps. The upload speed is the 1.9mbps. On pingtest, there is 0% packet loss, 30-40 ping and jitter between 1-4ms, with the occasional jump to 11ms of jitter.

Since that post to today, LiquidSky is still UNUSABLE. Every couple seconds, the client gets pixelated and buffers. Then it stops the screen issue, only to do it again a couple seconds later. Due to this, not even opening Steam on the SkyComputer is viable, hell not even watching a youtube video is possible. The client shows that the local ms is between 0-4ms, the latency to the server jumps from 60-68. Never goes beyond that. The client is running at 1 square of quality, the auto selector is ticked off. There is no change if I change the quality beyond 1 square or if I lower it to nothing, the blurry screen/pixelated image/buffering still happens. There is also no difference if I set LiquidSky to run at 720p/30 fps. The issues still happen. There is also no difference if I am the only one using the internet, with or without other things connected, I still suffer the same issues.

Before anyone jumps to the conclusion something is off with my laptop, I am not the only one using LiquidSky in my family. My brother does too. He too CAN NOT use LiquidSky on his laptop, he also connects to the modem* with an ethernet cable. He has the EXACT same issues as me .Blurry pixelated screen every few seconds. Gaming on LiquidSKy is simply UNPLAYABLE.

I've tried contacting LiquidSky support so that they might help me but so far they have not been useful. I've been told to talk with the ISP about potential packet loss, which I've done already via phone, but the after the tests they do, there is none.

When Speaking with the ISP, they claim there might be two reasons as to why LiquidSky is unusable:

Modem* firmware, which was not up to date OR having a dynamic IP. For the latter, they told me I could get a stable ip but that has a cost(quite elevated to be honest). As for the former, the tech in the phone told me to wait 24 hours for the modem* to update the firmware, I didn't buy into this last one so I told LiquidSky support about this.

Another stupidly annoying detail is the fact that, on my parents house, they have a 7mbps/ .64mbps upload internet connection, and both me and my brother can be connected at the same time to the modem* via ethernet and we can both use LiquidSky at the same time without much issue(the quality slider at 1-2 squares). On this one, not even having the quality slider at NOTHING allows us to use LiquidSky, hell even if only one attempts to use it at a time, LiquidSky is still unusable.

To be quite honest, nothing LiquidSky support has suggests has helped me in some way. I am really annoyed and disappointed that I can't use LiquidSky. I am running out of ideas on how to fix this. So please, if anyone has an idea or something I may try, please help me.

Edit: switched all router words for modem. I do not posses a router, only a modem to which my laptop and my brother's laptop are connected via ethernet.

Edit # 2: Big question, should any ports be forwarded/opened for LiquidSky to work? I was checking around in my modem's config and in the port forwarding section, it's completely empty, with the option to add something in, to put it that way.


#2

As a test, you can try connecting your laptop directly to your modem to rule out the router.

Edit: I'm assuming you're using a cable modem with separate router. If it's a combo modem/router, test the modem in bridge mode if you can.


#3

Have you checked you don't have any package loss?
Follow these instructions:


#4

Oh dear I just realized how badly worded this is.

I meant modem. I am connected directly to the modem. No router midway.


#5

Ill give it a try later and update the post.


#6

Everything is likely is to be fixed by the March update if it does what they advertise.


#7

From a performance standpoint, hopefully.

But this is a network issue. Something is off with my ISP and LiquidSky and I am trying to narrow it down so I can have them fix it asap.


#8

Here is some rather fishy stuff going on:

I launched liquidsky and stayed at the desktop for around 5 minutes. During those five minutes, I moved the mouse pointer randomly for a while, and the LOCAL ms goes nuts. It goes from 0 to 40, then comes back down and while its doing this, the screen gets all pixelated and buffers.

I thought I might have narrowed the issue to something related to upload speed(input from mouse) so I took it another step forward and opened a video on chrome. While the video played in fullscreen, I did the same thing, moved the pointer randomly on the screen. Again, tons of blurriness and buffers happening.

HOWEVER, i unplugged the mouse to see if it may have been the input but turns out that IT ISNT THE INPUT. Just watching the video, there is constant buffer and pixelation all around. The LOCAL ms still jumps from random values between 0 and 40.


#9

Sounds like you have a combo modem/router. If possible, try using it in bridge mode instead of gateway mode, i.e. so it functions as a modem only. (On my modem, there's a setting named "Residential Gateway Function" that I disable to put it in bridge mode. Might be something similar on yours.) Your laptop will then be directly connected to the Internet, and will obtain a public IP.

WARNING: Your laptop will be directly exposed to the Internet, so do not leave it like this for long. This is just to bypass the router functionality to rule it out as the culprit. Typically, the router aspect of a combo modem/router is weak.

However, if your parents have the same modem, then nevermind, because then obviously that's not what's hindering you since it works at your parents.


#11

*My parents have a different modem. Some weird brand I do not recall. The also have a different internet provider.

This one is huawei. It's pretty limited when it comes to fiddling around to change stuff. I'll try to give it a go with the bridge mode, if I can find the setting.

  • Gave the bridge thing a shot. Never found the setting on the router. I searched in all the tabs to no avail.

#12

Sorry to hear. But it was really a shot in the dark anyway, just to try to rule out one possibility, however slight.

If I had to guess, I'd say your problem has to do with the routing between you and the LS server, which you have no control over. I think that would be up to your ISP. Unfortunately, there's not much more I have to say about that -- I only have enough knowledge to be dangerous and/or annoying, but not always helpful :wink:

Can you connect to any other LS data center, even if it means higher latency?


#13

It's ok though. At least youre suggesting some possible fixes/reasons to the issue.

The other server I could connect to is dallas, but that one apparently has been in a coma for a while now lol.
Saddest part is that the dallas server has a 38ms ping, despite being 1500KM away, yet the one I am connected to has 60ms.


#14

Hi TacticalCatfish (awesome name by the way),

When I first got LS I experienced the same issues. I'm the UK, only 27ms away from my datacantre with an internet provider that gives me 150mbs down and 10 up (wired). I have a desktop, laptop and Shield all with LS installed. Games were unplayable, blurry screen and that weird glitch refresh thing that happened every 10-30 seconds from the top of the screen down to the bottom.

I didn't get any packet loss either. So I tested when no-one else was in the house. Made sure to disconnect anything that uses the internet so only my computer was plugged in and it was perfect.

I have since bought a router with QoS and with more control over how my household internet is used and am pleased to say that LS is much better since doing that and is even playable when my housemates have both their computers on and online gaming.

Try (if you can) testing LS when you know that only your laptop is connected and see what connection you get.

LS is a great service but so much of its quality depends on variables completely outside of LS's control...


#15

If @seiv15's suggestion doesn't help, here's another idea:

Try accessing LS through a VPN, if you can. If the route between you and the VPN server is good, and the route between the VPN server and LS is good, then hopefully that would bypass the poor route directly between you and LS (if that is indeed the problem). This might increase latency though, but it could give more consistency and maybe avoid pixelation and buffering.


#16

@bofforama I gave the VPN route a shot, the issue being, since I'm from Mexico, there aren't many VPN servers around here(at least for free that didn't look shady as hell), so I quickly discarded that idea.

So here is something interesting that @seiv15 recommends, the QoS. For some odd reason, the modem actually has that option(a quick google search showed it) but when I'm inside the control panel for it, the option is not there. I'll try contacting the ISP about it. As for using the internet when nobody is around, I've tried it. No dice, LiquidSky is still unplayable.

I also received another update from support asking me to use LS in the ULTRA package. I do not know how this could even fix the issue but I'll give it a shot.
EDIT: Yeah no, running LS on the Ultra package is the same thing as running it on the HIGH package. No changes, still unplayable.


#17

Update:

I called my ISP and talked about the issues I am experiencing with LS. The tech over the phone did a couple tests and this time he claims to have found issues with the connection to LiquidSky. Unfortunately, seeing as I don't have nor do I know the direct IP to the server I am connected (Queretaro, Mexico), they couldn't pinpoint the problem.

However, they told me that if LiquidSky support tells me how to fix it/what to fix, then the ISP can send a tech to my home and do the corresponding changes to fix this issue.

Now I only have to wait what LS support says about this so I can tell my ISP to send that tech. Hopefully this can fix the issue once and for all.


#18

Start your LS computer and open https://www.whatismyip.com/ or http://www.speedtest.net/ to get the IP.


#19

Liquidsky support is not helpful. You could be stuck on a bad server within Queretaro. You need to delete your sky computer and recreate it, then test. If it's still a problem delete it and create it on the next nearest server. If you have stability problems on multiple server locations then it's definitely a problem with your new ISP.

YouTube is not a good comparison since it has a massive buffer where liquid sky has pretty much no buffer to reduce response times. It requires a perfect connection that many ISP's have trouble offering.

I know deleting your sky computer is not most people's favorite option, but it's the only way to make any progress on this in my experience.


#20

Yeah LiquidSky support told me they'll message me back with the data the ISP can look after to fix the issue. That was 3 days ago.

However, I am happy to say today that, the issues seem to have resolved. I was away for 3 days from my apartment, today I came back and tested LiquidSky on both computers. 0 issues, unless forcing them to happen(downloading big files from the internet causes the same issues: blurry screens/pixelation/buffering).

I do not know if my ISP did something to their stuff while I was away, but it's been working flawlessly so far.

My brother has been playing for a while today and without any issues.
Hopefully this is it.

Thanks to everyone for suggesting stuff.