Optimization for a old laptop with a GT650M


#1

Hello LS-community,

i really enjoy to finally discover Dark Souls 3 on a Laptop which shouldn’t be able to run it in any way possible. However i have a lot of stutter, which doesn’t seem to come from the LS computer itself (checked the FPS there, constantly over 30) and from the latency as well since Quality-Adjuster in custom mode doesn’t do much. I messed a lot around with the control panel of NVIDIA (http://oi39.tinypic.com/6dsp6f.jpg) and it seems to make a difference from time to time. However i feel like i should be able to squeeze more out of it and i wonder if anyone of you guys has some recommendations for settings in the control panel.


#2

Use the “Use Advanced 3D Settings” instead of letting programs choose their settings. Not your fault since those settings come out of the box usually.

Under “Manage 3D Settings” on the Left I would usually leave “Global Settings” on whatever it is that it comes out of the box, because generally speaking it’s much better to go for individual programs IMO since sometimes individual programs play more nicely with some settings (see my next point below).

Personally I would set “Power Management Mode” to “prefer maximum performance” or “Nvidia driver controlled”. Test a little bit after downloading something like Nvidia Inspector (that measure performance numbers on your GPU). Those usually push the card more than it might’ve with default settings. You can mess around with other settings, but honestly considering that your chip is much better than mine (Kepler is the successor to Fermi), I don’t think you’ll need to mess around with other things than just the power management. Remember to keep your laptop plugged in if you don’t want to kill your battery :stuck_out_tongue:

Keep in mind that most of these settings will reset to default after a driver update, and I recommend backing them up with the Geforce 3D Profile Manager:
http://nvidia.custhelp.com/app/answers/detail/a_id/2625/~/after-updating-my-display-driver%2C-i-no-longer-see-nvapps.xml.-did-something

Apparently Nvidia Inspector has a profile saving tool as well, but I use this tool myself. See which one works for you I guess.

Let me know if you need any more help with this :slight_smile:

EDIT 11:44 EST- Just remembered to say: you need to enable your Nvidia GPU under preferred graphics processor. Otherwise it might just use your integrated :stuck_out_tongue_winking_eye: