[SOLVED] I paid monthly and i didnt receive


#1

Hi today i bought Liquidsky monthly for 20€ using paysafecard method and i paid and it confirmed it but when it return to the main page it was that a error has occured my money is gone and im pretty sure that i paid
Transaction ID of paysafecard: pay_1000001566_FRkfUMbLvoe2zQnjExFN0IgPA7MmvnR1_EUR

Please fix this for me

There is a print but its in portuguese (but i think it can serve as proof)


#2
  1. Logout of your client, then re-login
  2. If that doesn’t work, logout, delete your LiquidSky folder in %appdata%, re-download and reinstall the client, try again
  3. If that doesn’t work, contact support at https://liquidskysupport.zendesk.com/hc/en-us, they can sort it out for you.

#3

I tried the methods, ill have to contact support!
Thx for helping :smiley: ill try contacting


#4

Also contact Xsolla using their chat option


#5

Yea but i dont think i have anyproblem with xsolla, my payment was sent the only problem is liquidsky didnt gave me the monthly plan


#6

You dont lose anything by contacting them


#7

ill try contacting them then


#8

I have the same issue, I bought the pay-as-you-go plan, got 1500 credits. For the first day it said that I have to wait or purchase a plan to get instant access which I already did. Now after another day, it doesn’t say that I need to wait anymore to get in, but when I try to create a sky computer it says I don’t have enough credits even though in the upper left corner I see 1500 credits. No reply from the support after 2 days. Contacting Xsolla won’t help, they said they will not refund anything. Good luck anyway, this is the last time when I give a chance to this liquidysky.


#9

Have you tried the above steps 1 & 2 (re-login & redownload)?


#10

Let me see if there’s anything I can find out for you. Are you still having the same issue?


#11

Hi Ocean14,

I checked your account and see that the transaction pushed through even though you got that error. Also, I see that the SkyCredits were also allocated to you already as well.


#12

Sorry for the long time of the response but this has been already solved thanks sofia1


#13