XBOX 360 issues


#1

Hi There,

I bought a new xbox 360 controller and when I connected it to liquid sky i am getting really weird behavior.
1. down Dpad maps to xbox button
2. LT and RT are not mapped and can not be mapped
3. select button is mapped to down button
4. start button is mapped to down button

Please help


#2

In the menu there is a setup controller option where you have to map the buttons to liquidskys controller.


#3

Already tried...doesn't work. It doesn't allow me the map the correct keys.


#4

It can be a bit buggy. it took me quite a few tries to get the dpad mapped properly and one of the threads here someone had some tricks to get some other common problems with it sorted, but it does take quite a bit of fiddling to get it working properly.

Or it could be another issue. But I didn't find it easy to map.


#5

Are you experiencing these issues in a certain game or across all games in LiquidSky?

Thanks~


#6

Hi All,

Sorry for replying so late. I have fixed my problem.
The problem seems to be with Ubuntu and xboxdrv. xboxdrv is the open source driver available for ubuntu and is horribly buggy. I had a windows machine also, so tried running liquidsky on it and my x360 controller was working almost properly.

As of now the only problem I am facing on the windows platform is that I am unable to map the home button of my controller